Not loading Fire Mario hotbox?

Need help with any SMBX game-related issues? Ask your questions here.
TheIronWarrior
Fighter Fly
Fighter Fly
Posts: 60
Joined: Wed Dec 24, 2014 1:55 am

Not loading Fire Mario hotbox?

Postby TheIronWarrior » Sat Mar 19, 2016 4:01 pm

I am making a custom character, using ".ini" files for the hitbox so the sprite isn't all messed up. I got the hitbox for "mario-2.ini" to load, but the hitbox for "mario-3.ini' is just not loading for some reason. I am doing the exact same thing I did for "mario-2.ini", and I don't understand why it isn't working for "mario-3.ini"

Enjl
Cute Yoshi Egg
Cute Yoshi Egg
Posts: 8546
Joined: Mon Jan 20, 2014 12:58 pm
Flair: Orphion Egamalenitar Osmos IV, Esq.

Re: Not loading Fire Mario hotbox?

Postby Enjl » Sat Mar 19, 2016 4:29 pm

Can you tell me the name of the ini files and show me your code?
The ABC of Creation
________________________________________________________
Image

TheIronWarrior
Fighter Fly
Fighter Fly
Posts: 60
Joined: Wed Dec 24, 2014 1:55 am

Re: Not loading Fire Mario hotbox?

Postby TheIronWarrior » Sat Mar 19, 2016 4:36 pm

Enjl wrote:Can you tell me the name of the ini files and show me your code?
Code:

function onLoad()

Level.loadPlayerHitBoxes(1, 2, "mario-2.ini")
Level.loadPlayerHitBoxes(1, 3, "mario-3.ini")

end


Filenames:

"mario-2.ini"
"mario-3.ini"

Enjl
Cute Yoshi Egg
Cute Yoshi Egg
Posts: 8546
Joined: Mon Jan 20, 2014 12:58 pm
Flair: Orphion Egamalenitar Osmos IV, Esq.

Re: Not loading Fire Mario hotbox?

Postby Enjl » Sat Mar 19, 2016 4:39 pm

The only thing I can think of is that your mario-3.ini is somehow not what you think it is. It looks like it's being loaded, however maybe it's identical to the original?
The ABC of Creation
________________________________________________________
Image

User avatar
HenryRichard
Ludwig von Koopa
Ludwig von Koopa
Posts: 2846
Joined: Mon Dec 23, 2013 12:09 pm
Flair: Is this where I type my password?
Contact:

Re: Not loading Fire Mario hotbox?

Postby HenryRichard » Sat Mar 19, 2016 5:36 pm

I'm not entirely sure if this will fix it, but could you try using:
Level.loadPlayerHitBoxes(1, 2, "..\\mario-2.ini")
Level.loadPlayerHitBoxes(1, 3, "..\\mario-3.ini")
Jesus is my savior.

TheIronWarrior
Fighter Fly
Fighter Fly
Posts: 60
Joined: Wed Dec 24, 2014 1:55 am

Re: Not loading Fire Mario hotbox?

Postby TheIronWarrior » Sat Mar 19, 2016 6:02 pm

Enjl wrote:The only thing I can think of is that your mario-3.ini is somehow not what you think it is. It looks like it's being loaded, however maybe it's identical to the original?
Nope. I'm Positive.

EDIT: I tried loading "mario-2.ini" for mario-3.gif, and I am encountering the same problem; It is not loading the hitbox.


Return to “Help and Support”

Who is online

Users browsing this forum: No registered users and 16 guests