Need help with Error

General discussion about Super Mario Bros. X.
Animebryan
Snifit
Snifit
Posts: 245
Joined: Fri Jun 03, 2016 5:40 pm
Flair: Need help!
Contact:

Need help with Error

Postby Animebryan » Wed Oct 27, 2021 6:31 pm

A level I've spent a lot of time developing proved to be too long and hard so once again I had to scrap it & rebuild almost from scratch. I deleted every section's contents except for the first section & started to rebuild it from there. But when I tried to test play it to check on something, it gave me an error & now it wouldn't let me test play it.

Here's the error:

== Crash Summary ==
LunaLua Version: LUNALUA f2e4725
Exception Code: 0xc000008f (VB Error)
VB6 Error Code: 6 (Overflow)

== Stack Trace ==
0: 4FECD18F (MSVBVM60): rtcAnsiValueBstr
1: 00A07EA6 (smbx): InitNPC_orAnimFrame
2: 008CA385 (smbx): levelLoop
3: 008C224A (smbx): Sub_Main
4: 4FEB630C (MSVBVM60): EbLoadRunTime
5: 4FEB472F (MSVBVM60): EbSetContextWorkerThread
6: 4FEA7F6F (MSVBVM60): ThunRTMain
7: 4FEA7CB2 (MSVBVM60): ThunRTMain
8: 4FEA7BB8 (MSVBVM60): ThunRTMain
9: 0040BDE2 (smbx): start
10: 77929802 (ntdll): RtlInitializeExceptionChain
11: 779297D5 (ntdll): RtlInitializeExceptionChain

I have no idea what's causing this :cry:

Wohlstand
Charged Spiny
Charged Spiny
Posts: 1945
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Pronouns: he/him
Contact:

Re: Need help with Error

Postby Wohlstand » Thu Oct 28, 2021 4:07 pm

Could you upload your level with stuff here or DM me it (if you won't publish it yet)? I'll try to verify it, that's a possible little mistake in the data that is unnoticeable.

Animebryan
Snifit
Snifit
Posts: 245
Joined: Fri Jun 03, 2016 5:40 pm
Flair: Need help!
Contact:

Re: Need help with Error

Postby Animebryan » Thu Oct 28, 2021 6:13 pm

Wohlstand wrote:
Thu Oct 28, 2021 4:07 pm
Could you upload your level with stuff here or DM me it (if you won't publish it yet)? I'll try to verify it, that's a possible little mistake in the data that is unnoticeable.
How do I attach a File or Folder?

Wohlstand
Charged Spiny
Charged Spiny
Posts: 1945
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Pronouns: he/him
Contact:

Re: Need help with Error

Postby Wohlstand » Thu Oct 28, 2021 6:17 pm

Animebryan wrote:
Thu Oct 28, 2021 6:13 pm
Wohlstand wrote:
Thu Oct 28, 2021 4:07 pm
Could you upload your level with stuff here or DM me it (if you won't publish it yet)? I'll try to verify it, that's a possible little mistake in the data that is unnoticeable.
How do I attach a File or Folder?
Pack the directory into the archive (you may use 7zip, for example), and (here at SMBX forums you can't upload attachments) use one of the file exchange services or cloud storage to upload the archive you created, then give me a shared link generated on that place.

Animebryan
Snifit
Snifit
Posts: 245
Joined: Fri Jun 03, 2016 5:40 pm
Flair: Need help!
Contact:

Re: Need help with Error

Postby Animebryan » Thu Oct 28, 2021 7:30 pm


Wohlstand
Charged Spiny
Charged Spiny
Posts: 1945
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Pronouns: he/him
Contact:

Re: Need help with Error

Postby Wohlstand » Thu Oct 28, 2021 8:46 pm

Okay, I made the little investigation, and seems there is doze of paranormally placed "prizes", they were laying far off any sections, and they, looks like, causing the overflow crash because of their far location:
Image

And so, if you manually remove these lines via a text editor, you will fix your issue ;)

The star looks like, is also placed far off the section, you can quickly locate these NPC if you show these layers and use Editor's "find" toolbox.

Animebryan
Snifit
Snifit
Posts: 245
Joined: Fri Jun 03, 2016 5:40 pm
Flair: Need help!
Contact:

Re: Need help with Error

Postby Animebryan » Thu Oct 28, 2021 9:37 pm

I just recently deleted all the sections except for the first one so I wouldn't have to redo the entire level from scratch. Despite that, a single warp still lingered even though it was nowhere to be found. I figured the 'Delete Section' option would delete these objects but I guess not.

Edit: Yep, that fixed it. Thank you!
Last edited by Animebryan on Thu Oct 28, 2021 10:01 pm, edited 1 time in total.

Wohlstand
Charged Spiny
Charged Spiny
Posts: 1945
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Pronouns: he/him
Contact:

Re: Need help with Error

Postby Wohlstand » Thu Oct 28, 2021 9:42 pm

Animebryan wrote:
Thu Oct 28, 2021 9:37 pm
I just recently deleted all the sections except for the first one so I wouldn't have to redo the entire level from scratch. Despite that, a single warp still lingered even though it was nowhere to be found. I figured the 'Delete Section' option would delete these objects but I guess not.
The "Delete section" option deletes all objects that were inside the same section AND objects that were placed around with a given margin value (for example, if you had to put some blocks out of a section with a certain distance, and you want to get rid of them too).
Anyway, the fact some objects on hidden layers had survived the kill, I'll check some at Editor, was that my bug (I really should kill objects on hidden layers too when deleting section), or you had to delete these objects manually just by mouse selection or something, that caused hidden objects survived the apocalypse.

Added in 3 minutes 53 seconds:
Okay, damn... really, it's a bug, because of the next case:

The code that finds objects of the section to remove:
https://github.com/WohlSoft/Moondust-Pr ... #L321-L326

The documentation says about the items() call: https://doc.qt.io/qt-5/qgraphicsscene.html#items-1

....Returns all visible items that...

So, really, I will need to fix this up and make sure it will handle invisible objects too...

Added in 9 minutes 6 seconds:
So, I made an issue as a reminder to fix this bug as soon as possible (I will fix it really soon because I am in process of preparing the Moondust Devkit for the nearest stable release).

Wohlstand
Charged Spiny
Charged Spiny
Posts: 1945
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Pronouns: he/him
Contact:

Re: Need help with Error

Postby Wohlstand » Thu Jun 09, 2022 9:30 pm

Good news for you: I fixed that damned bug just now:
https://github.com/WohlSoft/Moondust-Pr ... 77501eec6c

So, please try to perform an update of Moondust Devkit (at X2, you need to run the "data/PGE/update_pge.cmd" script) after ~30 minutes since I posted this message.

Note: If you weren't updated the devkit after April 2021, you would encounter some issues, to resolve them, you need to:
- Ensure that the "data/PGE/configs/SMBX2 Integration/configure.js" file does not exist. If it exists, remove it.
- Edit the "data/PGE/configs/SMBX2 Integration/main.ini" file and change the "api-version=41" value into "api-version=42"

And then, Editor should work fine after the update.

yoorest2
Dolphin
Dolphin
Posts: 91
Joined: Fri Apr 01, 2022 8:59 am
Pronouns: he/him

Re: Need help with Error

Postby yoorest2 » Wed Jun 15, 2022 3:10 pm

so i'm not the one who has this

Animebryan
Snifit
Snifit
Posts: 245
Joined: Fri Jun 03, 2016 5:40 pm
Flair: Need help!
Contact:

Re: Need help with Error

Postby Animebryan » Wed Jul 06, 2022 5:45 pm

Wohlstand wrote:
Thu Jun 09, 2022 9:30 pm
Good news for you: I fixed that damned bug just now:
https://github.com/WohlSoft/Moondust-Pr ... 77501eec6c

So, please try to perform an update of Moondust Devkit (at X2, you need to run the "data/PGE/update_pge.cmd" script) after ~30 minutes since I posted this message.

Note: If you weren't updated the devkit after April 2021, you would encounter some issues, to resolve them, you need to:
- Ensure that the "data/PGE/configs/SMBX2 Integration/configure.js" file does not exist. If it exists, remove it.
- Edit the "data/PGE/configs/SMBX2 Integration/main.ini" file and change the "api-version=41" value into "api-version=42"

And then, Editor should work fine after the update.
Thank you!
yoorest2 wrote:so i'm not the one who has this
What the hell are you talking about & why are you posting here?

deice
Ripper II
Ripper II
Posts: 327
Joined: Fri Jul 23, 2021 7:35 am

Re: Need help with Error

Postby deice » Thu Jul 07, 2022 3:22 am

Animebryan wrote:
Wed Jul 06, 2022 5:45 pm
What the hell are you talking about & why are you posting here?
i believe they were trying to say that they'd also encountered this error, but their english is just not very good.

yoorest2
Dolphin
Dolphin
Posts: 91
Joined: Fri Apr 01, 2022 8:59 am
Pronouns: he/him

Re: Need help with Error

Postby yoorest2 » Thu Jul 07, 2022 4:24 pm

Animebryan wrote:
Wed Jul 06, 2022 5:45 pm
Wohlstand wrote:
Thu Jun 09, 2022 9:30 pm
Good news for you: I fixed that damned bug just now:
https://github.com/WohlSoft/Moondust-Pr ... 77501eec6c

So, please try to perform an update of Moondust Devkit (at X2, you need to run the "data/PGE/update_pge.cmd" script) after ~30 minutes since I posted this message.

Note: If you weren't updated the devkit after April 2021, you would encounter some issues, to resolve them, you need to:
- Ensure that the "data/PGE/configs/SMBX2 Integration/configure.js" file does not exist. If it exists, remove it.
- Edit the "data/PGE/configs/SMBX2 Integration/main.ini" file and change the "api-version=41" value into "api-version=42"

And then, Editor should work fine after the update.
Thank you!
yoorest2 wrote:so i'm not the one who has this
What the hell are you talking about & why are you posting here?
wdym?

Animebryan
Snifit
Snifit
Posts: 245
Joined: Fri Jun 03, 2016 5:40 pm
Flair: Need help!
Contact:

Re: Need help with Error

Postby Animebryan » Fri Jul 08, 2022 8:47 am

yoorest2 wrote:
Thu Jul 07, 2022 4:24 pm
Animebryan wrote:
Wed Jul 06, 2022 5:45 pm
Wohlstand wrote:
Thu Jun 09, 2022 9:30 pm
Good news for you: I fixed that damned bug just now:
https://github.com/WohlSoft/Moondust-Pr ... 77501eec6c

So, please try to perform an update of Moondust Devkit (at X2, you need to run the "data/PGE/update_pge.cmd" script) after ~30 minutes since I posted this message.

Note: If you weren't updated the devkit after April 2021, you would encounter some issues, to resolve them, you need to:
- Ensure that the "data/PGE/configs/SMBX2 Integration/configure.js" file does not exist. If it exists, remove it.
- Edit the "data/PGE/configs/SMBX2 Integration/main.ini" file and change the "api-version=41" value into "api-version=42"

And then, Editor should work fine after the update.
Thank you!
yoorest2 wrote:so i'm not the one who has this
What the hell are you talking about & why are you posting here?
wdym?
What do you mean?

yoorest2
Dolphin
Dolphin
Posts: 91
Joined: Fri Apr 01, 2022 8:59 am
Pronouns: he/him

Re: Need help with Error

Postby yoorest2 » Fri Jul 08, 2022 10:56 am

Animebryan wrote:
Fri Jul 08, 2022 8:47 am
yoorest2 wrote:
Thu Jul 07, 2022 4:24 pm
Animebryan wrote:
Wed Jul 06, 2022 5:45 pm

Thank you!


What the hell are you talking about & why are you posting here?
wdym?
What do you mean?
what do YOU mean? am just i didn't clicked the quote button so idk why my text appeared as quote, i just wanted to type this after clicking the repost button not the quote button in someone's repost


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest