Page 3 of 3

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Mon Jan 01, 2018 4:00 pm
by Electriking
OffensiveLemon wrote:
Electriking wrote:
OffensiveLemon wrote:The extra NPCs just show up as blinking black Goombas with question marks...
You should avoid this pack as it breaks the backwards compatibility with 2.0.
Well, I'm not using 2.0, so... I guess that doesn't matter that much.
2.0 players will be unable to play otherwise compatible levels using this pack, so you should avoid using this (as well as any other use of the dummy tiles) if you want to maximise appeal. You can use LunaLua to disable the behaviour of new for 2.0 features, and therefore not breaking compatibility by using this pack, but otherwise it is best to avoid it because it uses slots being used by the new features for 2.0.

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Mon Jan 01, 2018 6:25 pm
by OffensiveLemon
Electriking wrote:
OffensiveLemon wrote:
Electriking wrote: You should avoid this pack as it breaks the backwards compatibility with 2.0.
Well, I'm not using 2.0, so... I guess that doesn't matter that much.
2.0 players will be unable to play otherwise compatible levels using this pack, so you should avoid using this (as well as any other use of the dummy tiles) if you want to maximise appeal. You can use LunaLua to disable the behaviour of new for 2.0 features, and therefore not breaking compatibility by using this pack, but otherwise it is best to avoid it because it uses slots being used by the new features for 2.0.
Hm, I see...

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Wed Mar 28, 2018 6:23 pm
by Grand Goomba
This is very cool! SMBX2 will be able to use this graphics pack, will it? I mean, of course it won't work in Beta 3, but suppose it will work in Beta 4?

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Wed Mar 28, 2018 6:25 pm
by PixelPest
SMBX2 will not be supporting this graphics extension afaik since it's adding new blocks with new behaviours/properties

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Wed Mar 28, 2018 6:59 pm
by Enjl
Confirming what Pixelpest said. SMBXpanded was never intended to be compatible with SMBX2 and never will be. We might copy a few of the world map sprites over, though.

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Wed Mar 28, 2018 7:33 pm
by Grand Goomba
Neat! I'd like to see those World Map sprites, especially the Level sprites.

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Mon Apr 16, 2018 6:39 pm
by supermario0034
the link is broken! it says it's been deleted by the server

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Tue Apr 17, 2018 2:13 am
by Electriking
supermario0034 wrote:the link is broken! it says it's been deleted by the server
You shouldn't use this anyway.

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Fri Jun 05, 2020 9:32 am
by TheGreatMilkas
Where do i get the PGE for this?
I know 1.3.0.1. is dead by now,but i still use it.

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Fri Jun 05, 2020 10:24 am
by Cedur
PGE comes with SMBX2. Also read the above posts. There were issues with using this pack in X2 to begin with. (would it still be an issue in Beta 4?)

Re: SMBXpanded setup package (For SMBX 1.3, 1.3.0.1, and 1.3.0.X)

Posted: Fri Jun 05, 2020 10:35 am
by Enjl
Cedur wrote:
Fri Jun 05, 2020 10:24 am
would it still be an issue in Beta 4?
The only way for this to become compatible with SMBX2 would be for this pack to be redesigned to utilize the custom range (751-1000), which, at least for world map items, doesn't exist yet in smbx2.