SMBX 2.0 Open Beta

Topics about events/announcements that are no longer relevant.
KittyCat
Rex
Rex
Posts: 81
Joined: Sat Mar 12, 2016 6:04 am

Re: SMBX 2.0 Open Beta

Postby KittyCat » Sat Sep 10, 2016 6:17 am

Horikawa Otane wrote:Some new blocks....
Sweet!

So did the online feature get removed in this unofficial version of SMBX, or is it still there at the original alpha state it's in??
I'm a cat, so don't think I'm sstutering when I speak. - Haven't you seen movies where catss speak? *purrs*

Mario Pics:
Spoiler: show
Image

Enchlore
Mega Mole
Mega Mole
Posts: 273
Joined: Thu May 08, 2014 3:40 pm

Re: SMBX 2.0 Open Beta

Postby Enchlore » Sat Sep 10, 2016 1:30 pm

KittyCat wrote:So did the online feature get removed in this unofficial version of SMBX, or is it still there at the original alpha state it's in??
It wasn't really removed, it's left in the legacy editor, which is inaccessible.
Image

Mario123311
Goomba
Goomba
Posts: 2
Joined: Sun Sep 11, 2016 11:52 am

Re: SMBX 2.0 Open Beta

Postby Mario123311 » Sun Sep 11, 2016 11:56 am

Out of curiosity since I originally visited the "idea" thread and saw that it was locked... I remember seeing the preview for Klonoa and I was wondering - Think you could add one certain character...? :3
Image
Not that you have to of course, If needed I'll see if I can just make him a skin. ((I mainly wanted Pac-Man World-inspired gameplay with him))

User avatar
snoruntpyro
Pokey
Pokey
Posts: 223
Joined: Sun Oct 11, 2015 9:36 am
Contact:

Re: SMBX 2.0 Open Beta

Postby snoruntpyro » Sun Sep 11, 2016 3:06 pm

There are no plans to make any new characters until the full release for 2.0, which probably won't be coming for quite a while.
Spoiler: show
Image
Spoiler: show
Image

User avatar
SuperInky
Shy Guy
Shy Guy
Posts: 5
Joined: Sun Sep 11, 2016 6:05 pm

Re: SMBX 2.0 Open Beta

Postby SuperInky » Sun Sep 11, 2016 6:16 pm

Theres a problem: When i launch the editor, it says that i dont have the SMBX Integration Configuration Package. Then when i configured it, it doesn't happen to detect it anyways. Help?? (I registered today (11/9/16) , but by the way i knew SMBX long time ago.)

Enjl
Cute Yoshi Egg
Cute Yoshi Egg
Posts: 8417
Joined: Mon Jan 20, 2014 12:58 pm
Flair: Orphion Egamalenitar Osmos IV, Esq.

Re: SMBX 2.0 Open Beta

Postby Enjl » Sun Sep 11, 2016 6:36 pm

SuperInky wrote:Theres a problem: When i launch the editor, it says that i dont have the SMBX Integration Configuration Package. Then when i configured it, it doesn't happen to detect it anyways. Help?? (I registered today (11/9/16) , but by the way i knew SMBX long time ago.)
I'm assuming you have the most recent version of PGE (0.3.1.10 and newer support the SMBXInt config as far as I know), but you'll also need a recent version of LunaLua. 0.7.3.0 isn't recent enough, so if you have that, click the "Download the latest Nightly/Dev build" button and update your LunaLua that way. Do make sure you have the "Latest" version before doing that, though. If you're uncertain as to which version you have, do the following:
-Download "Latest" and select "Full Installation" to make sure you have all the files from 0.7.3.0
-Download the dev build to get all your files up to date.
The ABC of Creation
________________________________________________________
Image

User avatar
HenryRichard
Ludwig von Koopa
Ludwig von Koopa
Posts: 2846
Joined: Mon Dec 23, 2013 12:09 pm
Flair: Is this where I type my password?
Contact:

Re: SMBX 2.0 Open Beta

Postby HenryRichard » Sun Sep 11, 2016 6:44 pm

I really love those Kirby blocks! Now all we really need is a Kirby playable (I think I had an incomplete one at some point that I was working on, so this is by no means a request)
Jesus is my savior.

User avatar
Wohlstand
Boom Boom
Boom Boom
Posts: 1778
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Current Project: Moondust (PGE Project)
Chat Username: Wohlstand#4881
Contact:

Re: SMBX 2.0 Open Beta

Postby Wohlstand » Sun Sep 11, 2016 7:18 pm

Enjl wrote:0.3.1.10
I'll fix you: latest PGE Editor is 0.3.1.11 since recent update finally published
PGE Project, my Media and supported projects: show
Support me on the Patreon
Image

PGE Project
PGE Project SMBX Topic
PGE Project Official Site and forums
Download fresh experimental builds HERE!

I'm support:
Lowser's Conquest by Sednaiur

Image
P.S. I don't like huge signatures which would be annoying, therefore I put huge content into spoilers

Enjl
Cute Yoshi Egg
Cute Yoshi Egg
Posts: 8417
Joined: Mon Jan 20, 2014 12:58 pm
Flair: Orphion Egamalenitar Osmos IV, Esq.

Re: SMBX 2.0 Open Beta

Postby Enjl » Sun Sep 11, 2016 7:25 pm

Wohlstand wrote:
Enjl wrote:0.3.1.10
I'll fix you: latest PGE Editor is 0.3.1.11 since recent update finally published
I said "0.3.1.10 and newer". Of course you should always have the most recent build, but I was just saying that if he already has 0.3.1.10 it would work too if his lunalua was up to date.
The ABC of Creation
________________________________________________________
Image

User avatar
SuperInky
Shy Guy
Shy Guy
Posts: 5
Joined: Sun Sep 11, 2016 6:05 pm

Re: SMBX 2.0 Open Beta

Postby SuperInky » Sun Sep 11, 2016 7:28 pm

Enjl wrote:
SuperInky wrote:Theres a problem: When i launch the editor, it says that i dont have the SMBX Integration Configuration Package. Then when i configured it, it doesn't happen to detect it anyways. Help?? (I registered today (11/9/16) , but by the way i knew SMBX long time ago.)
I'm assuming you have the most recent version of PGE (0.3.1.10 and newer support the SMBXInt config as far as I know), but you'll also need a recent version of LunaLua. 0.7.3.0 isn't recent enough, so if you have that, click the "Download the latest Nightly/Dev build" button and update your LunaLua that way. Do make sure you have the "Latest" version before doing that, though. If you're uncertain as to which version you have, do the following:
-Download "Latest" and select "Full Installation" to make sure you have all the files from 0.7.3.0
-Download the dev build to get all your files up to date.
This didn't fixed the problem, i still keep getting that i have an old Configuration Package, and i have all the files UP TO DATE. Help??

User avatar
Yoshi021
Gold Yoshi Egg
Gold Yoshi Egg
Posts: 633
Joined: Thu Jan 21, 2016 9:06 pm
Flair: :)
Chat Username: SetaYoshi

Re: SMBX 2.0 Open Beta

Postby Yoshi021 » Sun Sep 11, 2016 7:46 pm

SuperInky wrote:
Enjl wrote:
SuperInky wrote:Theres a problem: When i launch the editor, it says that i dont have the SMBX Integration Configuration Package. Then when i configured it, it doesn't happen to detect it anyways. Help?? (I registered today (11/9/16) , but by the way i knew SMBX long time ago.)
I'm assuming you have the most recent version of PGE (0.3.1.10 and newer support the SMBXInt config as far as I know), but you'll also need a recent version of LunaLua. 0.7.3.0 isn't recent enough, so if you have that, click the "Download the latest Nightly/Dev build" button and update your LunaLua that way. Do make sure you have the "Latest" version before doing that, though. If you're uncertain as to which version you have, do the following:
-Download "Latest" and select "Full Installation" to make sure you have all the files from 0.7.3.0
-Download the dev build to get all your files up to date.
This didn't fixed the problem, i still keep getting that i have an old Configuration Package, and i have all the files UP TO DATE. Help??
Try using these...
http://wohlsoft.ru/docs/_laboratory/config_packs/
"Going to University is FUN!"
DOWNLOAD THE SMBX LEVEL PLAYER
CHECK OUT MY NPC PACK

Join the SMBX Episode Project Discord Server
Image

Join the SMBX 38A Discord!
Image

Join the CodeHaus Discord!
Image
Image

User avatar
SuperInky
Shy Guy
Shy Guy
Posts: 5
Joined: Sun Sep 11, 2016 6:05 pm

Re: SMBX 2.0 Open Beta

Postby SuperInky » Sun Sep 11, 2016 7:52 pm

Yoshi021 wrote:
SuperInky wrote:
Enjl wrote: I'm assuming you have the most recent version of PGE (0.3.1.10 and newer support the SMBXInt config as far as I know), but you'll also need a recent version of LunaLua. 0.7.3.0 isn't recent enough, so if you have that, click the "Download the latest Nightly/Dev build" button and update your LunaLua that way. Do make sure you have the "Latest" version before doing that, though. If you're uncertain as to which version you have, do the following:
-Download "Latest" and select "Full Installation" to make sure you have all the files from 0.7.3.0
-Download the dev build to get all your files up to date.
This didn't fixed the problem, i still keep getting that i have an old Configuration Package, and i have all the files UP TO DATE. Help??
Try using these...
http://wohlsoft.ru/docs/_laboratory/config_packs/
I already has patched the Configuration Package, BUT IT STILL SAYS THAT!

User avatar
Wohlstand
Boom Boom
Boom Boom
Posts: 1778
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Current Project: Moondust (PGE Project)
Chat Username: Wohlstand#4881
Contact:

Re: SMBX 2.0 Open Beta

Postby Wohlstand » Mon Sep 12, 2016 1:16 am

SuperInky wrote:
Yoshi021 wrote:
SuperInky wrote: This didn't fixed the problem, i still keep getting that i have an old Configuration Package, and i have all the files UP TO DATE. Help??
Try using these...
http://wohlsoft.ru/docs/_laboratory/config_packs/
I already has patched the Configuration Package, BUT IT STILL SAYS THAT!
Check carefully, you seems unpacked into WRONG directory. You must extract into "configs" subfolder in PGE application directory, and you must have INIs in one depth level, I.e.: ./configs/SMBXInt/*.ini
Or you seems patching a wrong PGE assembly. If you installed it via installer, it stored in Program Files. You can get new online installer and set all necessary config packs to install
PGE Project, my Media and supported projects: show
Support me on the Patreon
Image

PGE Project
PGE Project SMBX Topic
PGE Project Official Site and forums
Download fresh experimental builds HERE!

I'm support:
Lowser's Conquest by Sednaiur

Image
P.S. I don't like huge signatures which would be annoying, therefore I put huge content into spoilers

User avatar
PokemonLyle
Spiny
Spiny
Posts: 58
Joined: Sat Nov 29, 2014 2:35 am
Current Project: None
Contact:

Re: SMBX 2.0 Open Beta

Postby PokemonLyle » Mon Sep 12, 2016 8:37 am

I really really really hope Nintendo doesn't shut SMBX 2.0 down.
I love playing video games | My YouTube https://www.youtube.com/channel/UC23jm5 ... OjB4tdVaTA | I support ImageImage Image

Mable
Peach
Peach
Posts: 5835
Joined: Sat Dec 21, 2013 4:23 am
Current Project: Account soon to be deleted
Chat Username: Account soon to be d
Contact:

Re: SMBX 2.0 Open Beta

Postby Mable » Mon Sep 12, 2016 9:50 am

PokemonLyle wrote:I really really really hope Nintendo doesn't shut SMBX 2.0 down.
Shhh don't bring them ideas like this in the head.

User avatar
SuperInky
Shy Guy
Shy Guy
Posts: 5
Joined: Sun Sep 11, 2016 6:05 pm

Re: SMBX 2.0 Open Beta

Postby SuperInky » Tue Sep 13, 2016 3:48 pm

Wohlstand wrote:
SuperInky wrote:
Yoshi021 wrote: Try using these...
http://wohlsoft.ru/docs/_laboratory/config_packs/
I already has patched the Configuration Package, BUT IT STILL SAYS THAT!
Check carefully, you seems unpacked into WRONG directory. You must extract into "configs" subfolder in PGE application directory, and you must have INIs in one depth level, I.e.: ./configs/SMBXInt/*.ini
Or you seems patching a wrong PGE assembly. If you installed it via installer, it stored in Program Files. You can get new online installer and set all necessary config packs to install
Thanks, i packed it now, sad that I cant use the SMBX2.0 launcher, but I can with the PGE Editor.

EDIT: Or maybe -bruh- I dont know how to pack this. Can... ...you make a tutorial of packing it?

User avatar
Wohlstand
Boom Boom
Boom Boom
Posts: 1778
Joined: Tue Feb 11, 2014 4:44 pm
Flair: 狐エンジニア
Current Project: Moondust (PGE Project)
Chat Username: Wohlstand#4881
Contact:

Re: SMBX 2.0 Open Beta

Postby Wohlstand » Tue Sep 13, 2016 4:46 pm

SuperInky wrote:
Wohlstand wrote:
SuperInky wrote:
I already has patched the Configuration Package, BUT IT STILL SAYS THAT!
Check carefully, you seems unpacked into WRONG directory. You must extract into "configs" subfolder in PGE application directory, and you must have INIs in one depth level, I.e.: ./configs/SMBXInt/*.ini
Or you seems patching a wrong PGE assembly. If you installed it via installer, it stored in Program Files. You can get new online installer and set all necessary config packs to install
Thanks, i packed it now, sad that I cant use the SMBX2.0 launcher, but I can with the PGE Editor.

EDIT: Or maybe -bruh- I dont know how to pack this. Can... ...you make a tutorial of packing it?
In the SMBX 2.0 repo, config pack is already pre-included and ready for work. To use classic SMBX Integration (which available separately) with SMBX 2.0, you must point it to SMBX 2.0, or just goto "Configuration" -> "Run configure tool" and then choice SMBX 2.0 directory, then restart PGE Editor
PGE Project, my Media and supported projects: show
Support me on the Patreon
Image

PGE Project
PGE Project SMBX Topic
PGE Project Official Site and forums
Download fresh experimental builds HERE!

I'm support:
Lowser's Conquest by Sednaiur

Image
P.S. I don't like huge signatures which would be annoying, therefore I put huge content into spoilers

User avatar
FanofSMBX
Bowser
Bowser
Posts: 3881
Joined: Sun Dec 22, 2013 12:01 pm

Re: SMBX 2.0 Open Beta

Postby FanofSMBX » Tue Sep 13, 2016 8:32 pm

Will making custom sprites/NPCs be easier than SMW ASM? Because that culture over there seems very toxic to me due to how people mostly reuse sprites that other people made and making repetitive hacks due to that and annoying skilled ASM people with requests.

I believe in Jesus Christ as my Lord and Savior. If you do, put this in your signature.
My graphics pack!
Supporting forums:

Spoiler: show
SMBX Galaxy forum by Pivot40Channel
http://smbxgalaxy.prophpbb.com/
Come to the SMBX+ forums by illias3000. There is a whole forum category dedicated to the boss rush series with official rushes, submit bosses, and fan boss rushes! It is still open but AirSeus Forums is now open:
http://nsmbx.prophpbb.com/
AirSeus Forums the new home of the Boss Rush series:
http://smbxairseusforums.prophpbb.com/
Spoiler: show
First to discover:
Spark
Eerie
Grinder
Rainbow Shell
Birdo
Boom Boom
Image
Image
Image
Image
Image
KINGBOWSER112 RULES!


Enjl
Cute Yoshi Egg
Cute Yoshi Egg
Posts: 8417
Joined: Mon Jan 20, 2014 12:58 pm
Flair: Orphion Egamalenitar Osmos IV, Esq.

Re: SMBX 2.0 Open Beta

Postby Enjl » Tue Sep 13, 2016 8:53 pm

FanofSMBX wrote:Will making custom sprites/NPCs be easier than SMW ASM? Because that culture over there seems very toxic to me due to how people mostly reuse sprites that other people made and making repetitive hacks due to that and annoying skilled ASM people with requests.
ASM is code which is what the program will directly read. Lua is a few layers of accessibility above that. Getting into lua and understanding how it works is much easier than the same for ASM. As for sprites, you don't need specific tools like yychr to open up your sheet and you aren't restricted to a set palette. Just grab your image editing sofware of choice and make them as pngs in a sheet formatted just the way you want. As for placing, the easiest way is to choose an npc you won't use and use its ID but modify all of its behaviour. Projectile NPCs like bowser fire or wart bubbles are good for this. Here's an example:
http://hastebin.com/lerubikoke.lua (apologies for potentially unpolished code) (most of this code is setting the frame displayed)
The result is this mossy enemy which you can see in the video below. It uses a shy guy NPC and its hitboxes, modified with a .txt.
https://youtu.be/FM6ABKAbIEk?t=92
The spritesheet looks as follows:
Image

Hope that cleared things up for you!
The ABC of Creation
________________________________________________________
Image

User avatar
migueeel
Rex
Rex
Posts: 94
Joined: Thu Jun 04, 2015 12:09 pm

Re: SMBX 2.0 Open Beta

Postby migueeel » Sun Sep 18, 2016 2:00 pm

*coughing in middle of the silence*

No news I guess? It's just, everything went so silent.. xD
I was there when Link was added, SMBX 2 was announced (it was a joke, including stuff that you'd play as Redigit, you'd have to pay for it, etc), when those two admins banned like half the community...

I'm using the same avatar as back then.


Return to “Events and Announcements”

Who is online

Users browsing this forum: No registered users and 5 guests