Page 2 of 2

Re: The Great Giana's Adventure (1.4.4 REQUIRED)

Posted: Fri Dec 29, 2017 3:00 pm
by Super Luigi!
I don't have much criticism for you, since I like how everything looks. The cream pipe outline is a bit distracting, but it might fit in better in other levels.

Re: The Great Giana's Adventure (1.4.4 REQUIRED)

Posted: Sat Dec 30, 2017 6:52 pm
by GianaSistersfan64
Just some minor update that the demo will be available when i will finish the world 3 and redo old levels. It will take so long. Also i will maybe add some easter eggs (yes i love secret stuff in video games)!

Edit : I've made some touches the cream pipe for underground levels.
Image

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Mon Jan 08, 2018 2:06 pm
by GianaSistersfan64
Newest levels!

Level 3-6
Spoiler: show
Image
Level 3-7 (boss level)
Spoiler: show
Image
Image
Image
Image
Image
Image
Image
Level 3-8
Spoiler: show
Image
Note : There's some sprites that who have not been modified and there's some points i have forgotten to fix or added. The ship graphics belong to Sednaiur.

(Sorry for my bad english)

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Tue Jan 09, 2018 10:18 pm
by WildWEEGEE
Can I help? I'm not really a Giana sisters fan but I use smbx 1.4 and probably some of the only help the community will offer (1.4.x is usually not a supported version)

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 8:53 am
by GianaSistersfan64
WildWEEGEE wrote:Can I help? I'm not really a Giana sisters fan but I use smbx 1.4 and probably some of the only help the community will offer (1.4.x is usually not a supported version)
The only help i need is for the player hitbox and animation frame but if you want to help me for that, you can.

Re: The Great Giana's Adventure (1.4.4 REQUIRED)

Posted: Wed Jan 10, 2018 9:57 am
by Eri7
Taycamgame wrote:This looks really nice, but 3-4 looks a lot longer than the other levels. Also, that cream coloured pipe thing really stands out and doesn't suit the level, but it would probably look better if it was a shade of blue.
Other than that, this project looks great!
EDIT: But I realised that it is for 1.4.4, so I guess I won't be playing it anytime soon (unless it is made compatible with 2.0).
I like the level timer idea. Not sure if that is a 1.4.4 feature, but if it is something like lunalua, do you think you could send me the code for it?
The level timer is default feature in 38A/1.4.4 that can be accessed through events , even if he did have the code for the timer it wouldn't work on 2.0 because Teascript and Luna lua are 2 different scripting languages.
Side note : Also i think that your response about making it compatible with 2.0 might be taken as an offence to someone because if someone choose to make his episode in one version then there is a reason why its in this specific version , please dont take this as a fact but as an opinion , you have the right to disagree with me.

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 11:23 am
by Taycamgame
Hmm, didn't think it would be regarded as an offence... Nevertheless, I hope this project goes well!

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 12:01 pm
by Electriking
Wait, so suggesting to make a version of a project for another version of SMBX is offensive? Not that it would be a necessary suggestion since you can just download 1.4 if you want to play episodes for that version.

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 12:41 pm
by Eri7
Electriking wrote:Wait, so suggesting to make a version of a project for another version of SMBX is offensive? Not that it would be a necessary suggestion since you can just download 1.4 if you want to play episodes for that version.
He didn't suggest anything , just said that he will rather play it on 2.0 than 38A(also he said that he wont play the episode anytime soon if it was made only for 38A and is kinda a sign of discrimination towards his project because its made in 38A , now should the creator feel bad because he made it in 38A, of course NOT!) and that implies that he wants the creator of the project to convert it into 2.0 and thats offensive because first , the creator put hard work into his project and to do it over again in another engine that doesnt support the functions of 1.4 will give him problems with converting it especially if he is not a big fan of PGE , second that is disrespectful because instead of playing the original version of the episode , he wants the creator to work twice as hard to provide him with another version that might suck alot more than his original.But a good suggestion i think would be , i will first play the original version and tell you how to improve it and if you decide to convert it to 2.0 then it would be great to use the advices of others upon improving the episode. Anyways , i just gave out my opinions and i will say it again , you have the right to disagree with me.

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 1:21 pm
by GianaSistersfan64
Eri7 wrote:
Electriking wrote:Wait, so suggesting to make a version of a project for another version of SMBX is offensive? Not that it would be a necessary suggestion since you can just download 1.4 if you want to play episodes for that version.
He didn't suggest anything , just said that he will rather play it on 2.0 than 38A(also he said that he wont play the episode anytime soon if it was made only for 38A and is kinda a sign of discrimination towards his project because its made in 38A , now should the creator feel bad because he made it in 38A, of course NOT!) and that implies that he wants the creator of the project to convert it into 2.0 and thats offensive because first , the creator put hard work into his project and to do it over again in another engine that doesnt support the functions of 1.4 will give him problems with converting it especially if he is not a big fan of PGE , second that is disrespectful because instead of playing the original version of the episode , he wants the creator to work twice as hard to provide him with another version that might suck alot more than his original.But a good suggestion i think would be , i will first play the original version and tell you how to improve it and if you decide to convert it to 2.0 then it would be great to use the advices of others upon improving the episode. Anyways , i just gave out my opinions and i will say it again , you have the right to disagree with me.
I'm agree with you. I don't want to do a version for 2.0 because it will be very hard convert a 38A episode to 2.0 and i have some script that will be important for the episode. Also 38A have some things that 2.0 don't have (like timer, other NPCs and the GFX-Expansion UI). Also the first demo will come soon when i will finishe by redoing old levels.

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 2:41 pm
by WildWEEGEE
GianaSistersfan64 wrote:
WildWEEGEE wrote:Can I help? I'm not really a Giana sisters fan but I use smbx 1.4 and probably some of the only help the community will offer (1.4.x is usually not a supported version)
The only help i need is for the player hitbox and animation frame but if you want to help me for that, you can.
Sorry for late repsonse... I'm not good with spriting but maybe I might be able to make a level for your project just pm me the gfx your using if interested

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 3:33 pm
by GianaSistersfan64
WildWEEGEE wrote:
GianaSistersfan64 wrote:
WildWEEGEE wrote:Can I help? I'm not really a Giana sisters fan but I use smbx 1.4 and probably some of the only help the community will offer (1.4.x is usually not a supported version)
The only help i need is for the player hitbox and animation frame but if you want to help me for that, you can.
Sorry for late repsonse... I'm not good with spriting but maybe I might be able to make a level for your project just pm me the gfx your using if interested
Hmm... Well the demo will realise in two week or more (because of school). And you will have the sprites in the folder. But i don't really need level designer, sorry.

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 6:00 pm
by WildWEEGEE
GianaSistersfan64 wrote:
WildWEEGEE wrote:
GianaSistersfan64 wrote: The only help i need is for the player hitbox and animation frame but if you want to help me for that, you can.
Sorry for late repsonse... I'm not good with spriting but maybe I might be able to make a level for your project just pm me the gfx your using if interested
Hmm... Well the demo will realise in two week or more (because of school). And you will have the sprites in the folder. But i don't really need level designer, sorry.
Understood. Good luck :D

Re: The Great Giana's Adventure (1.4.4 REQUIRED + poll)

Posted: Wed Jan 10, 2018 6:20 pm
by goombaguy
Woah a Giana Sisters project???
This is some real interesting stuff right here. Good luck and I hope to see this project finished sometime!