Custom backgrounds arent working

Share and discuss custom SMBX graphics.
Forum rules
Before you make a topic/post, consider the following:
-Is there a topic for this already?
-Is your post on-topic/appropriate?
-Are you posting in the right forum/following the forum rules?
-Do not create a topic requesting custom graphic. Do so in Graphic Request.
User avatar
SuperSpaceMan230
Cheep-Cheep
Cheep-Cheep
Posts: 14
Joined: Sat Nov 05, 2016 4:24 pm

Custom backgrounds arent working

Postby SuperSpaceMan230 » Thu Sep 05, 2019 6:33 am

So, i imported a custom background, and it works in the editor, but for some reason, it doesnt work ingame

Image

This is how it looks in the editor

Image

But this is how it looks ingame

I used the default background file (the one that generates when you click the edit button with a backgorund), can someone please help me fix this?

EDIT: The SMB3 blocks background seems to be not working for me, but other backgrounds work fine for some reason

Image

Kirby's jam of the week


User avatar
FireyPaperMario
Peach
Peach
Posts: 5060
Joined: Sat Sep 27, 2014 1:39 pm
Flair: 90's kid born in late 1993 ^_^
Current Project: As of now: SEGA Mega Drive/Genesis GFXs in SMBX
Chat Username: Shin FireyPaperMario
Contact:

Re: Custom backgrounds arent working

Postby FireyPaperMario » Thu Sep 05, 2019 6:43 am

Did you save the custom background image as a png file? Or is it larger than the original background image that this happens?

User avatar
SuperSpaceMan230
Cheep-Cheep
Cheep-Cheep
Posts: 14
Joined: Sat Nov 05, 2016 4:24 pm

Re: Custom backgrounds arent working

Postby SuperSpaceMan230 » Thu Sep 05, 2019 6:49 am

FireyPaperMario wrote:
Thu Sep 05, 2019 6:43 am
Did you save the custom background image as a png file? Or is it larger than the original background image that this happens?
Its a png and its the same size the original background file.

Image

Kirby's jam of the week


User avatar
FireyPaperMario
Peach
Peach
Posts: 5060
Joined: Sat Sep 27, 2014 1:39 pm
Flair: 90's kid born in late 1993 ^_^
Current Project: As of now: SEGA Mega Drive/Genesis GFXs in SMBX
Chat Username: Shin FireyPaperMario
Contact:

Re: Custom backgrounds arent working

Postby FireyPaperMario » Thu Sep 05, 2019 6:50 am

SuperSpaceMan230 wrote:
Thu Sep 05, 2019 6:49 am
FireyPaperMario wrote:
Thu Sep 05, 2019 6:43 am
Did you save the custom background image as a png file? Or is it larger than the original background image that this happens?
Its a png and its the same size the original background file.
Oh, maybe it's a glitch.... I don't know

User avatar
SuperSpaceMan230
Cheep-Cheep
Cheep-Cheep
Posts: 14
Joined: Sat Nov 05, 2016 4:24 pm

Re: Custom backgrounds arent working

Postby SuperSpaceMan230 » Thu Sep 05, 2019 6:57 am

FireyPaperMario wrote:
Thu Sep 05, 2019 6:50 am
SuperSpaceMan230 wrote:
Thu Sep 05, 2019 6:49 am
FireyPaperMario wrote:
Thu Sep 05, 2019 6:43 am
Did you save the custom background image as a png file? Or is it larger than the original background image that this happens?
Its a png and its the same size the original background file.
Oh, maybe it's a glitch.... I don't know
Dont worry, i think i can use another background instead of the complex ones with multiple graphics, they seem to be broken

Image

Kirby's jam of the week


User avatar
Enjl
Cute Yoshi Egg
Cute Yoshi Egg
Posts: 7566
Joined: Mon Jan 20, 2014 12:58 pm
Flair: Orphion Egamalenitar Osmos IV, Esq.

Re: Custom backgrounds arent working

Postby Enjl » Thu Sep 05, 2019 1:19 pm

They're not broken. There's probably just something you're doing wrong. If you want to know what it is, please share an image of the contents of your level folder, showing all files related to the backgrounds.
ImageImageImageImage
ImageImageImageImageImageImage


Return to “Graphics”

Who is online

Users browsing this forum: No registered users and 4 guests